#

Supported Browsers




We support the following browsers (as of 5/17/2017):
Minimum requirements
Windows 7 / 8 / 10
Microsoft Internet Explorer (IE) 8.0 newer
Mozilla Firefox 37.x and newer
Google Chrome 31.x and newer

Mac
Apple Safari 5.x and newer
Mozilla Firefox 37.x and newer
Google Chrome 31.x and newer

Recommended requirements
Windows Vista / 7 / 8

Microsoft Internet Explorer (IE) 11.0 and newer
Mozilla Firefox 37.x and newer
Google Chrome 41.x and newer

Mac

Apple Safari 8.x and newer
Mozilla Firefox 37.x and newer
Google Chrome 41.0.x and newer

*Javascript needs to be enabled on the browser. Also, adding bakercounty.org website to the Internet Explorer Compatibility View list should enable most features to work in the event that content is not displaying properly.